afficher les menus
Connexion
Pseudo : 

Mot de passe : 


mot de passe égaré ?

S'inscrire !
Thèmes
screenshot

(7 thèmes)
Qui est en ligne
1 utilisateur(s) en ligne (dont 1 sur Documentation en ligne)

Membre(s): 0
Invité(s): 1

plus...
Qui est passé ?

Mooky
85 jours 20 heures 14 minutes
[Retour | Afficher cette page en format imprimable]

Page soumise par Mooky


<= Page précédante <= Sommaire => Page suivante =>

4.3. Voyons à quoi ressemble Gus.


Nous ne pouvons pas attendre plus longtemps et nous voulons voir notre premier rendu! Mais d'abord nous devons effectuer un certain nombre d'ajustements.

1. Maintenez MAJ appuyé en cliquant LMB sur le calque 1 (le calque de Gus) puis sur le calque 10 (le calque de la caméra), comme sur la Figure 4-19.

Figure 4.19. Rendre les calques 1 et 10 visibles.

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick19.png

Rappelez-vous que le dernier calque sélectionné est le calque actif, ainsi tous les ajouts éventuels apparaîtront automatiquement sur le calque 10.

2. Sélectionnez la caméra (RMB) et positionnez-la sur (x=7, y=-10, z=7). Vous pouvez appuyer sur GKEY et déplacer la camera en maintenant CTRL appuyé pour la contraindre à se déplacer par pas d'un carreau de la grille.

blender.doc.fr.free.fr/relecture/html/stylesheet-images/tip.gif Entrer des valeurs précises pour la position et la rotation
Si vous préférez saisir des valeurs numériques pour l'emplacement d'un objet vous pouvez appuyer sur NKEY et changer les valeurs "NumButtons" dans la boite d'entrée numérique qui apparaît (Figure 4-20). Appuyez bien sur OK pour sauvegarder les valeurs.


Figure 4-20. Fenêtre proprieté de l'objet position/rotation etc…

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick20.png

Pour pointer la caméra sur Gus, gardez la caméra sélectionnée, puis cliquez sur Gus en maintenant MAJ-RMB. La caméra deviendra Magenta et Gus rose clair. Appuyez Ctrl-T et choisissez l'entrée Old Track dans le menu flottant. Ceci forcera la caméra à suivre Gus et à toujours s'orienter vers lui. Cela signifie que quel que soit l'endroit où vous déplacerez la caméra, Gus sera toujours au centre de vision de celle-ci.

http://blender.doc.fr.free.fr/relecture/html/stylesheet-images/tip.gifTracking ( objet "suiveur" )
Si "l'objet suiveur" a déjà ses propres rotations, ce qui est souvent le cas, le résultat de Ctrl-T pourrait ne pas être ce qui a été prévu.

Sélectionnez dans ce cas "l'objet suiveur", dans notre exemple la caméra, et appuyez Alt-R pour enlever toutes les rotations liées à cet objet. Ceci fait, la caméra suivra correctement Gus !
Le schéma 4-21 montre les vues de dessus, de face, de coté et de la caméra de Gus. Pour obtenir la vue de la caméra appuyez sur NUM0.


Le schéma 4-21. Position de la caméra avec Gus.

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick21.png

Maintenant nous avons besoin d'un sol sur lequel Gus peut se tenir.

1. Dans la vue supérieure (NUM7), et hors du mode d'édition ajoutez un plan SPACE>>ADD>>Mesh>>Plane .

blender.doc.fr.free.fr/relecture/html/stylesheet-images/tip.gif Il est important d'être sorti du mode d'édition, autrement le nouvel l'objet sera ajouté comme une partie de l'objet actuel en mode d'édition. C'était le cas pour la tête de Gus quand nous l'avons ajoutée. Si le curseur se trouve où nous le montre la figure 4-21, le sol (le plan) sera au milieu de la tête de Gus.

2. Passez en Mode Objet et vue de face (NUM1) et déplacez (GKEY) le plan vers le bas, aux pieds de Gus, en utilisant CTRL pour le maintenir aligné avec Gus.

3. Passez du curseur comme centre de référence (c'est ce que nous avions fait au début) au centre de l'objet comme centre de référence en validant le bouton mis en surbrillance de la Figure 4-22.

4. Passez en vue Camera (NUM0) et, avec le plan toujours sélectionné, appuyez sur SKEY pour commencer la mise à l'échelle.


Le schéma 4-22. Placer le centre de référence au centre de l'objet.

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick22.png

5. Elargissez le plan, de sorte que ses bords soient en dehors du champ de vision de la caméra. Ceci est indiqué par le rectangle à tiret blanc externe dans la vue de caméra.

Maintenant un peu de lumière!

1. Dans la vue de dessus (NUM7) ajoutez un éclairage de type Lampe (SPACE>>ADD>>Lamp) devant Gus, mais pas du même côté que la caméra, par exemple dans (x=-9, y=-10, z=7) (Figure 4-23).


Le schéma 4-23. Insertion d'une Lampe.

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick23.png

2. Validez Lamp Buttons par l'intermédiaire du bouton avec une lampe dans le Button Window toolbar (Figure 4-24) ou utilisez F5.

Le schéma 4-24. Le bouton de fenêtre de Lamp Buttons.

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick24.png

3. Dans la fenêtre de boutons (Buttons Window), appuyez sur le bouton à bascule Spot pour faire de la lampe un spot (Figure 4-25) (R=1, G=1, B=0.9) de couleur jaune pâle. Ajustez les boutons numériques ClipSta : à 5, Samples : à 4 et à Soft : à 8.

Le schéma 4-25. Configurations du spot.

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick25.png

4. Faites de ce spot un "objet suiveur" de GUs exactement comme il a été fait pour la caméra. Sélectionnez le Spot, SHIFT puis Gus, et enfin en appuyez sur Ctrl-T. Si vous avez ajouté le spot dans la vue de dessus, vous ne devriez pas avoir besoin d'annuler les rotations par l'intermédiaire d'Alt-R.

5. Au même endroit que le Spot, et toujours dans la vue de dessus, ajoutez une deuxième Lampe (SPACE>>ADD>>Lamp). Faites de celle-ci une lampe "Hemi" avec sa puissance (Energy) à 0.6 (Figure 4-26).

Le schéma 4-26. Les configurations de lampe "Hemi".

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick26.png

http://blender.doc.fr.free.fr/relecture/html/stylesheet-images/tip.gif Deux lampes ?

Avoir deux lampes ou plus permet d'avoir un éclairage doux et réaliste. Dans la réalité la lumière ne vient jamais d'un seul point. Vous en apprendrez plus à ce sujet dans le chapitre sur l'éclairage.


Nous sommes presque prêts à effectuer notre rendu. Allez d'abord au Render Buttons en appuyant sur l'icone ressemblant à une image dans le Button Window toolbar (Figure 4-27) ou appuyez sur F10.


Le schéma 4-27. Le bouton d'acces au paramètres de rendu.

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick27.png

Dans l'onglet Format fixez la taille d'image à 640x480 à l'aide des boutons numériques en haut à droite de la fenêtre des paramètres. Dans l'onglet Render au centre activez le bouton Shadows, et activez aussi le bouton OSA au centre-gauche (Figure 4-28). Ces dernières commandes permettront de rendre visible les ombres et à l'oversampling (OSA) d'empêcher les bords déchiquetés.

Le schéma 4-28. La fenêtre de Rendering Buttons

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick28.png

Vous pouvez maintenant cliquer le bouton RENDER ou faire un F12. Le résultat est montré sur le schéma 4-29… et est quelque peu pauvre. Nous avons besoin de lui appliquer des matériaux! Et un bon nombre de détails, tels que des yeux, etc…

Le schéma 4-29. Votre premier rendu. Félicitations !

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick29.png

http://blender.doc.fr.free.fr/relecture/html/stylesheet-images/tip.gifLa sauvegarde

/!\ Si vous ne l'avez pas encore fait, c'est le bon moment pour sauvegarder votre travail, par l'intermédiaire du menu enregistrement de fichier représenté sur Figure 4-30, ou Ctrl-W-KEY.

Blender vous avertit toujours si vous essayez d'écraser un fichier existant.

Blender fait des sauvegardes automatiques dans le répertoire temporaire de votre système. Par défaut, ceci se produit toutes les 4 minutes et le nom de fichier est un nombre. Charger ces sauvegardes est un autre moyen d'annuler des changements indésirables.

Le schéma 4-30. Le menu principal avec les fonctions importantes dont l'enregistrement.

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick30.png




4.4. Matériaux et Textures



Maintenant que Gus est créé, il est temps de lui appliquer une matière appétissante, ayant l'aspect d'un biscuit.

1. Pour accéder aux paramètres des textures, activez le bouton avec une sphère rouge qui se trouve dans la barre d'outils de la Fenêtre des Boutons (Figure 4-31) ou utilisez le raccourci clavier F5.


Figure 4-31. Le bouton des matériaux de la barre d'outils.

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick31.png


2.La fenêtre de Butons sera presque vide parce que Gus n'a pas encore de matière valide. Pour en créer une nouvelle, cliquez sur le bouton Menu dans l'onglet Material sur le bouton (celui avec, à gauche, deux triangles pointant vers le haut et le bas) et validez ADD NEW ( Figure 4-32).

Figure 4-32. Le bouton d'accès au menu liste des matériaux.

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick32.png


3. De nouveaux boutons ainsi qu'une barre de texte apparaîtront à côté du bouton blanc carré. Remplacez le nom mis par défaut, par quelque chose de signicatif, comme "pain d'épice" (Bouton gauche LMB dans la barre de texte suffit a activer le curseur de saisie de texte).

4. Modifiez les valeurs par défaut selon le schéma 4-33 pour obtenir un premier matériel approximatif.

Figure 4-33. La fenêtre des matériaux et la première matière "Pain d'épice"

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick33.png


5. Appuyez le bouton Menu ADD NEW, à droite de la fenêtre des paramètres des Matériaux, dans l'onglet Texture (Figure 4-34). Nous ajoutons une texture dans le premier canal. Donnez-lui un nom comme "GingerTex"

Figure 4-34. Le bouton de la liste des textures.

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick34.png


6. Pour accéder aux paramètres des Textures, cliquez sur le bouton carré "peau de panthère" (Schéma 4-35) ou appuyez sur F6.

Figure 4-35. Le bouton d'accès aux paramètres des textures.

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick35.png


7. En sélectionnant Stucci dans la rangée supérieure de Bouton, tous les paramètres de celle-ci apparaissent comme sur la Figure 4-36.

Figure 4-36. Fenêtre des paramètres de texture pour l'élément "Stucci" activé.

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick36.png


8. Retournez aux paramètres des Matériaux (F5) et modifiez les paramètres des onglets Map Input et Map To comme dans le schéma 4-37 ( ).
Désactivez le bouton "Col", activez le bouton "Nor", faites glisser le curseur Nor à 0.750 ce qui aura pour résultat de donner du relief à votre texture et Gus ressemblera encore plus à un biscuit.

Figure 4-37. Paramètres de la texture Stucci dans la fenêtre des matériaux.

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick37.png


9. Maintenant, ajoutez une deuxième texture, nommez-la "le Grain". Donnez-lui de l'effet en positionnantant le paramètre Var sur 0.4 de la propriété Ref (comme sur le schéma 4-38). La texture elle-même devient une texture de bruit.

Figure 4-38. Paramètres pour la texture de bruit du deuxième canal.

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick38.png


Appliquez au sol une matière appropriée. Par exemple, le bleu foncé comme dans la Figure 4-39.

Figure 4-39. Une matière très simple pour le sol.

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick39.png


Pour la touche finale, nous devons ajouter des yeux et quelques autres détails.

1. D'abord assurez-vous que le calque 1 est le seul visible en cliquant avec LMB sur le premier bouton des calques (Figurez 4-40). Cela cachera les lampes, la caméra et le sol.

Figure 4-40. Boutons de visibilité des calques sur la barre d'outils.

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick40.png


2. Placez le curseur au centre de la tête de Gus, souvenez-vous que vous travaillez en 3 dimensions, donc vous devez vérifier au moins sur deux vues pour être sûr!

3. Ajoutez une sphère (ESPACE > > ADD > > Mesh > > UVsphere). On vous demandera le nombre de segments: (méridiens) et d'anneaux: (parallèles) pour construire la sphère. Le nombre par défaut de 32 est trop grand dans ce cas, donc employez une valeur de 16 pour les deux. La sphère est dans la première image de la séquence de la Figure 4-41.

4. Réduisez-la (SKEY) jusqu'à un facteur de 0.1 dans toutes les dimensions, passez ensuite à la vue de côté (NUM3) et changez d'échelle seulement dans la direction horizontale (SKEY et YKEY) jusqu'à un facteur de 0.5 (voir la seconde des deux images de la Figure 4-41).


Figure 4-41. Chronologie de la création des yeux.

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick41.png


5. Zoomez un peu si nécessaire avec NUM + ou MW ou CTRL-MMB et déplacez la sphère (GKEY) à gauche pour qu'elle soit à moitié dedans et à moitié hors de la tête (première image de la deuxième rangée (Figure 4-41)).

6. Revenez à la vue de face (NUM1) et déplacez la sphère sur le côté droit où Gus devrait avoir un oeil.

7. Créez un double de l'oeil de la même manière que nous avons dupliqué le reste du corps. (Activez le bouton de barre d'outils qui passe le curseur comme référence, en Mode Edition, sélectionnez tout avec AKEY, MAJ-D (fait une copie), ESC(sortir du mode de déplacement), MKEY(ouverture du menu Miroir), choisir Global X). Maintenant Gus a deux yeux.

8. Sortez du mode d'édition (TAB) et placez le curseur comme vous le pouvez au centre du visage de Gus. Ajoutez une nouvelle sphère en modifiant sa taille comme nous l'avons fait plus tôt, mais faites-la plus petite et placez-la plus bas à droite du curseur, centrée sur le croisement de la 1ère subdivision. (Figure 4-42).

Figure 4-42. Création d'une bouche avec l'outil Filage.

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick42.png


9. Maintenant, dans les boutons d'édition (F9), localisez le groupe de boutons en bas dans le panneau d'outils Mesh (le schéma 4-43). Entrez les valeurs suivantes Degr : à 90, Steps: à 3, et vérifiez que le bouton Clockwise: ("dans le sens des aiguilles d'une montre") est activé. Puis, avec tous les sommets toujours sélectionnés, pressez le bouton "SpinDup". Ceci créera trois copies des sommets sélectionnés sur un arc de 90 degrés, et avec pour centre de rotation, le curseur. Le résultat devrait être la bouche de Gus, comme sur la dernière image de la Figure 4-42.

Figure 4-43. Les outils de rotation dans la fenêtre des paramètres d'édition

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick43.png


Maintenant que vous maîtrisez cet outil, ajoutez encore trois ellipsoïdes pour former les boutons de Gus. Une fois réalisé le premier, sortez simplement du Mode Edition, puis avec MAJ-D créez un double et positionnez le comme montré dans la Figure 4-44.

Figure 4-44. Gus en entier !

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick44.png


Donnez aux yeux une matière resemblant à du chocolat, comme celui montré en haut de la figure 4-45. Donnez à la bouche une matière sucre blanc, comme la seconde représentation sur la figure 4-45, et donnez aux boutons les matières, sucre rouge, blanc, et vert. Celles-ci sont montrées sur les dernières représentations de la figure 4-45.

Figure 4-45. Quelques matières à l'aspect de sucre.

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick45.png


Objets partageant un même matériau

Pour qu'un objet ait le même matériau qu'un autre, il faut sélectionner ce matériau dans la liste ouverte par le bouton du menu des matériaux dans la fenêtre des paramètres des matériaux.

Figure 4-46. Sélectionner une matière existante dans le menu des matériaux.

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick46.png


Une fois que vous avez fini d'assigner des matériaux, affichez le calque 10 (vous devriez désormais savoir comment...), de sorte que les lampes et la caméra soient visibles également, et faites un nouveau rendu (F12). Le résultat doit être très proche de la Figure 4-47.

Figure 4-47. Gus fini et rendu. N'est il pas croquant?

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick47.png


Enregistrez votre image, si vous le désirez, en pressant F3. Entrez le nom de votre image dans la fenêtre d'enregistrement des images et appuyez sur Save .


http://blender.doc.fr.free.fr/relecture/html/stylesheet-images/tip.gifTypes d'image et extentions de fichier.

Vous devez choisir le format d'images (JPEG, PNG, et ainsi de suite) dans la fenêtre des paramètres de rendu avant de faire F3 (Figure 4-27) et utiliser le menu (Figure 4-48) de l'onglet Format. Blender n'ajoute pas automatiquement l'extension au fichier; vous devez en entrer un, si vous le désirez.

Figure 4-48. Menu format d'image dans la fenêtre des paramètres de rendu.

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick48.png




4.5. Armature


Si l'objectif avait été d'obtenir une image fixe, à ce stade, nous en aurions terminé, mais nous voulons "animer" Gus! L' étape suivante sera de lui procurer un squelette, une armature, pour l'animer facilement. C'est l'art délicat du "Rigging".

Gus aura une armature assez simple : quatre membres, (deux bras et deux jambes), quelques articulations (pas de coudes, des genoux uniquement), mais ni pieds ni mains.

Pour ajouter l'armature :

1. Placez le curseur à l'emplacement adéquat de l'épaule, ajoutez une armature à cet endroit en appuyant sur SPACE>>ADD>>Armature. Un objet de forme "rhomboïdale" (en forme de losange) apparaîtra, un élément du système d'armature, extensible depuis le curseur jusqu'au pointeur de souris. Placez l'autre extrémité de l'armature au niveau de la main de Gus avec LMB ( voir Figure 4-49). Cela "fixera" cet élément et en créera un nouveau à partir du point de terminaison, construisant ainsi une "chaîne" d'éléments. Comme nous n'avons pas besoin d'autres éléments, pour le moment, sortons de cette chaîne par ESC.

Figure 4-49. Pose du premier élément, un bras non articulé.

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick49.png

2. Restez en Mode Edition, amenez le curseur à la jointure de la hanche et créez une nouvelle armature (SPACE>>ADD>>Armature) qui ira jusqu'au genou. Une pression sur LMB et une nouvel élément apparaît automatiquement à la suite. Agrandissez-la jusqu'au pied (Figure 4-50).

Figure 4-50. Ajout des deuxième et troisième éléments, chaîne de l'armature de la jambe.

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick50.png

http://blender.doc.fr.free.fr/relecture/html/stylesheet-images/tip.gif Position de l'ossature

Les éléments que nous ajoutons déformeront le maillage du "corps de Gus". Pour avoir un résultat satisfaisant, essayez de placer les articulations comme montré dans les illustrations.

3. Maintenant placez le curseur au centre et sélectionnez tous les éléments avec AKEY. Dupliquez-les avec Shift-D, sortez du mode déplacement avec ESC puis avec MKEY, faites une copie symétrique par rapport au curseur et à "l'axe Global" X comme vous l'aviez fait pour les maillages avec XKEY (Figure 4-51).

Figure 4-51. Armature complète après duplication et copie symétrique.

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick51.png

Une fois que vous avez sélectionné tous les éléments (AKEY), la fenêtre "Edit Buttons" affiche un panneau Armature Bones qui montre les boutons d'armature (Figure 4-52).

Figure 4-52. Fenêtre "Edit Buttons" pour une armature.

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick52.png

Appuyez sur le bouton Draw Names (affichage des noms) pour voir ceux des éléments, puis SHIFT-LMB sur les noms dans la fenêtre de bouton d'édition (Figure 4-52) pour les remplacer par des appellations plus appropriées comme Arm.R, Arm.L, UpLeg.R, LoLeg.R, UpLeg.L, et LoLeg.L. Sortez du Mode d'édition avec (TAB).

http://blender.doc.fr.free.fr/relecture/html/stylesheet-images/tip.gif Dénomination des éléments

Il est très important de désigner les éléments par un suffixe '.L' ou '.R' pour distinguer ceux de gauche de ceux de droite, de sorte que "Action Editor" (l'éditeur d'action) puisse inverser automatiquement vos poses.



4.6. Le Skinning


Maintenant nous devons faire en sorte qu'une déformation dans l'armature entraine une déformation similaire du corps. Nous appelons cette étape le Skinning, cet exercice consiste à affecter des sommets du maillage aux éléments de l'armature de sorte que les mouvements des uns soient assujettis aux mouvements des autres.

1. Sélectionnez le corps de "Gus", puis en maintenant MAJ sélectionnez aussi l'armature de telle sorte que le corps devienne magenta et l'armature rose clair (l'ordre de sélection est important).
2. Avec CTRL-P "apparentez" le corps à l'armature. Un menu flottant souvre sous la souris (Figure 4-53). Sélectionnez l'entrée Use Armature .

Figure 4-53. Le menu Flottant s'ouvrant lors de l'apparentage d'un objet avec une armature.

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick53.png

3. Un nouveau menu apparaît pour demander si vous voulez que Blender ne fasse rien, qu'il crée des groupes de vertices non assignés ou qu'il crée et rassemble des groupes de vertices pré-assignés. (Figure 4-54).

Figure 4-54. Options de l'assignation automatique du "Skinning".

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick54.png

4. Nous allons utiliser l'option d'assignation automatique du "skinning". Allez-y, sélectionnez Create From Closest Bones (Créer à partir de l'élément le plus proche).

Maintenant, ne sélectionnez que le corps de Gus et passez en Mode Edition (TAB). Vous noterez dans la Fenêtre d'Edition des Boutons (F9) et dans le panneau Mesh Tools 1 la présence "VertexGroup" (boutons et menu).

Figure 4-55. Les boutons de groupes de vertex dans la fenêtre des boutons d'édition d'un maillage.

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick55.png

En appuyant sur le " Menu Button" (2 petits triangles inversés) apparaît un menu déroulant avec tous les groupes de vertex disponibles (six dans notre cas), mais une représentation véritablement complexe, avec des pieds et des mains complètement équipés pourrait en avoir des dizaines! (Figure 4-56). Les boutons Select et Deselect vous montre quels vertices appartiennent à quel groupe.

Figure 4-56. Menu avec les groupes de vertex crées automatiquement dans le processus de "skinning".

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick56.png

Sélectionnez le groupe du bras droit (Arm.R) et, avec tous les vertices désélectionnés (AKEY, si besoin) appuyez sur Select. Vous verrez quelque chose comme Figure 4-57.

Figure 4-57. Gus en EditMode avec tous les vertices du groupe "Arm.R" sélectionnés.

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick57.png

Les sommets surlignés par des cercles jaunes (Figure 4-57) appartiennent au groupe de déformation mais ils ne le devraient pas. Le processus "d'autoskinning" a déterminé qu'ils étaient très proches des éléments et les a donc associés au groupe de déformation. Nous n'en voulons pas dans ce groupe car certains appatiennent à la tête et d'autres à la poitrine. Les ajouter au groupe de déformation déformeraient également ces parties du corps. Pour les faire disparaître du groupe, désélectionnez tous les autres, ceux qui doivent rester dans le groupe, en utilisant la boite de sélection (BKEY), mais se servir de MMB et non pas LMB pour délimiter la "boite" de manière à ce que tous les sommets inclus dans le rectangle soient désélectionnés. Pour ce faire, commencez par la désélection des vertices du dessus du bras avec BKEY + MMB puis recommencez pour ceux du dessous.

Une fois que les sommets 'indésirables' sont sélectionnés, appuyez sur Remove (Figure 4-55) pour les éliminer du groupe "Arm.R".

Désélectionnez tout (AKEY) puis accédez à un autre groupe.Vérifiez-les tous et assurez-vous qu'ils ressemblent à ceux de la Figure 4-58.

Figure 4-58. Les six groupes de vertices.

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick58.png


Vertex groups

Soyez attentif lorsque vous affectez ou supprimez des sommets à un groupe de vertex. Si ultérieurement vous constatez des déformations inattendues, il est probable que vous en avez oubliés ou au contraire, que vous en avez placés en trop dans le groupe. A tout moment il vous est possible de modifier les groupes de vertex.

Autres détails

Le corps de Gus sera affecté par nos déformations, mais les yeux, la bouche ou les boutons qui sont des objets distincts ne le seront pas. Si ceci n'est pas une finalité à prendre en considération dans cette animation simple, elle doit être prise en compte pour des projets plus complexes, par exemple lors de l'apparentement ou d'autres types de jonction des diverses pièces d'un corps pour construire une maillage unique. (Nous décrirons toutes ces options en détail dans de futurs chapitres).



4.7. Pose


Maintenant que vous avez donné à "Gus" un squelette et que sa peau y est bien accrochée, Vous allez pouvoir commencer à jouer avec lui comme avec un mannequin, manipuler ses os et regarder le résultat.

1. Sélectionnez seulement l'armature, activez maintenant Pose Mode (le mode Pose) dans le Menu "Mode" (Figure 4-59) ou avec CTRL-TAB. Ce mode particulier n'apparaît que si une armature est sélectionnée.

Figure 4-59. Le menu pour passer en Mode Pose, dans la barre d'outils de la fenêtre 3D.

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick59.png

2. L'armature devient bleue, vous êtes en Mode Pose. Si maintenant vous sélectionnez un élément (bone), il devient cyan et pas rose et si vous le déplacez (GKEY), ou le faites tourner (RKEY), le corps de se déformera !

Figure 4-60. Vous êtes en mode pose maintenant !
http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick60.png
Position d'Origine

Blender se souvient de la position d'origine des éléments. Vous pouvez revenir sur cet état de l'armature en appuyant sur le bouton RestPos? (Restaurer la position) parmi les boutons d'édition "Armature" (schéma 4-52).

Cinématiques Avant et Inverses
Lors des manipulations des éléments en mode pose vous noterez qu'ils agissent en tant que corps rigides et inextensibles et comportent des joints sphériques à l'extrémité. Vous ne pouvez réellement déplacer que le premier élément d'une chaîne et tous les autres le suivront. Tous les éléments qui viennent après dans la chaîne ne peuvent pas être saisis et déplacés, vous pouvez seulement leur appliquer une rotation, de sorte que l'élément sélectionné effectue une rotation au niveau de sa jonction avec l'élément précédent, tous les éléments suivants de la chaîne le suivent alors dans sa rotation.

Ce procédé appelé Forward Kinematics (FK) (Cinématiques Avant) est facile à suivre, mais il rend difficile la position précise du dernier élément de la chaîne. Vous pouvez employer une autre méthode, Inverse Kinematics (IK) (Cinématiques Inverses) avec laquelle vous définissez réellement la position du dernier élément de la chaîne, tous les autres prenant alors une position, automatiquement calculée par Blender, pour placer correctement les éléments de la chaîne. De cette façon, le positionnement précis des mains et des pieds est beaucoup plus facile.

Nous ferons marcher Gus en définissant quatre poses différentes, relatives aux quatre étapes successives d'une enjambée. Blender effectuera le travail de création d'une animation fluide.

1. D'abord, vérifiez que vous êtes à l'image 1 de la "timeline". Le numéro de l'image apparaît dans un bouton à valeur numérique à la droite de la barre d'outils de la Fenêtre des Boutons (Figure 4-61). S'il n'indique pas 1, placez-vous à 1 en maintenant appuyés CTRL+flèche basse.

Figure 4-61. Le bouton numérique d'image courante dans la fenêtre barre d'outils.

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick61.png

2. Maintenant, en appliquant une rotation à un seul élément à la fois (RKEY), soulevez l'élément "UpLeg.L" et pliez "LoLeg.L" vers l'arrière; soulevez un peu "Arm.R" et abaissez "Arm.L", comme représenté sur le schéma 4-62.

Figure 4-62. Notre première pose.

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick62.png

3. Sélectionnez tous les éléments avec AKEY. Avec le curseur de souris sur la fenêtre 3D, appuyez sur IKEY. Un menu flottant apparaît Figure 4-63. Choisissez LocRot à partir de ce menu. La position et l'orientation de tous ces éléments sont stockées dans une pose à l'image numéro 1. Cette pose représente Gus au milieu de son enjambée, alors qu'il fait avancer sa jambe gauche au-dessus du sol.

Figure 4-63. Affecter et conserver la Pose à une image.

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick63.png

4. Déplacez-vous maintenant à l'image 11 en écrivant le nombre dans "NumButton" (le Bouton numérique) ou avec UPARROW (FlècheVersLeHaut). Déplacez alors Gus à une position différente, comme Figure 4-64, avec sa jambe gauche en avant et la droite en arrière, toutes les deux légèrement pliées. Gus marche sur place!

Figure 4-64. Notre seconde pose.

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick64.png

5. Choisissez à nouveau tous les éléments et appuyez sur IKEY pour stocker cette pose à l'image 11.

6. Nous avons besoin maintenant d'une troisième pose à l'image 21, avec la jambe droite vers le haut, parce que nous sommes au milieu de l'autre moitié du pas. Cette pose est le "miroir" de celle que nous avons définie à l'image 1. Par conséquent, retournez à l'image 1 et, dans le menu Armature dans l'en-tête de la fenêtre 3D choisissez Copy Pose (copier pose) (Figure 4-65). Vous avez copié la pose courante dans le tampon mémoire (Buffer).

Figure 4-65. Copier la pose dans le tampon mémoire

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick65.png

7. Allez à l'image 21 et collez la pose avec l'option Paste Flipped Pose (Coller la Pose Inversée) dans le menu Armature (Figure 4-66). Ce bouton collera la pose, en intervertissant les positions des éléments avec le suffixe ".L" et celles des éléments avec le suffixe ".R", effectuant effectivement une pose inversée!

Figure 4-66. Coller la copie en tant que nouvelle pose, inversée.

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick66.png

La pose existe mais elle n'a pas encore été stockée! Vous devez appuyer sur IKEY avec tous les éléments sélectionnés..

8. Appliquez maintenant le même procédé pour copier la pose de l'image 11 à l'image 31, en l'inversant également.

9. Pour accomplir le cycle de marche, nous devons copier la pose de l'image 1 sans l'inverser et la coller à l'image 41. Faites-le en la copiant comme d'habitude, et en employant Paste Pose (Coller Pose). Finissez la séquence en stockant la pose avec IKEY.

Vérification de l'animation
Pour visionner directement votre animation, placez l'image courante à 1 et la pressez Alt+A dans la fenêtre 3D.



4.8. Gus marche !


Un simple cycle de pas sur place est la base de la marche, et une fois que vous en avez défini un il existe des techniques pour faire qu'un personnage déambule selon un parcours plus élaboré. Mais, dans le cadre de notre "QuickStart" (Départ rapide), un unique cycle de pas sur place sera suffisant.

Passez aux "RenderingButtons?" (boutons du panneau de Rendu) (F10) et positionnez l' animation pour qu'elle débute ("Stat:") à 1 et finisse ("End:") à 40 (Figure 4-67). Sachant que l'image 41 est identique à l'image 1, nous avons seulement besoin d'obtenir le rendu des images de 1 à 40 pour produire un cycle de marche complet.

Figure 4-67. Utilisation des boutons de rendu pour une animation.

http://blender.doc.fr.free.fr/BlenderManual2.4_fr/PartI/quick_start/gfx/Quick67.png

2. Sélectionnez "AVI Raw" comme format de fichier vidéo dans le panneau Format (Figure 4-67). Cela n'est généralement pas le meilleur choix, en particulier pour la taille du fichier qu'il génere (ce sera expiqué plus tard), mais ce format est rapide et est supporté par tous les systèmes, cela convient très bien pour l'instant. (Vous pourriez aussi sélectionner "AVI Jpeg" pour produire un fichier plus compact, mais en utilisant la compression Jpeg vous perdriez en qualité et obtiendriez un film qui ne pourrait pas être lu par certains visualiseurs externes.)

3. Finalement, cliquez sur le bouton ANIM dans le Panneau Anim. Souvenez-vous que tous les Calques que vous voulez utiliser dans l'animation doivent être visibles! Dans le cas présent, ce sont les Calques 1 et 10.

Arrêt d'un Rendu

Si vous faite une erreur, comme oublier de rendre visible le Calque 10, vous pouvez stopper le processus de rendu avec la touche ESC.

Notre scène est particulièrement simple et Blender fera le rendu des 40 images en seulement quelques secondes. Regardez les au fur et à mesure qu'elles apparaissent.

images fixes

Bien sûr vous pouvez toujours faire le rendu de chacune des images de votre animation (image fixe) en sélectionnant l'image dont vous voulez obtenir le rendu et en cliquant sur le bouton RENDER.

Une fois que le rendu est achevé vous devriez obtenir un fichier nommé 0001_0010.avi dans un sous-répertoire render de votre répertoire courant - celui qui contient votre fichier ".blend". Vous pouvez le visionner directement dans Blender en cliquant le bouton Play en dessous du bouton ANIM (Figure 4-67). L'animation démarrera aussitôt. Pour l'arrêter appuyez sur ESC.

Nous avons seulement fabriqué un cycle de marche très primaire. Il y a beaucoup plus à faire dans Blender et nous allons bientôt le découvrir!

<= Page précédante <= Sommaire => Page suivante =>


[Retour | Afficher cette page en format imprimable]

Page soumise par Mooky